Saturday, May 14, 2011

Cisco Phones And Asterisk 1.8.4, Registration Problems? Solved.

Cisco Phones, Asterisk 1.8.4

If you upgraded your Asterisk server to Asterisk 1.8.4 and suddenly your Cisco phones fail to register (which worked fine in Asterisk 1.8.3) with your Asterisk server,  the issue seemed to be a patch related to chan_sip and reqresp_parser missing from this release.

There is a solution. Either you can wait for Asterisk 1.8.5 RC1 or test with the Asterisk 1.8 branch. Both includes the patch or the fix.

You can read the bug report here.


Blog Widget by LinkWithin